Jump to content
magu

6-kanałowy sterownik LED - AQma LED Control v3 - by magu

Recommended Posts

7 godzin temu, domelsjz napisał:

Na winXP po kablu śmiga a próba połączenia przez Bluetooth wywala program.

Że ktoś jeszcze używa XP ;) 

Na W10 i W7 bez problemu łączy się przez BT.

Share this post


Link to post
Share on other sites

Pochwalę się i Marcina oczywiście.

Zaadaptowałem AQMA'ę do lamp tzw. chinek. Każda z nich przegrzebana i powymieniane profilaktycznie led'y- jedna bez WiFi, druga z uszkodzonym WiFi. Powisiały chwilę i zapragnąłem żeby nie odpalały od razy maxem. A że w szufladzie leży kilka Arduino Nano to od pomysłu do realizacji nie było daleko. Wszystko ładnie upchnięte do środka także na zewnątrz nic nie widać.

Do wersji bez WiFi dołożyłem przełącznik 6 pinowy (WiFi-Manual), zasilacz i przycisk reset oraz oczywiście Nano+RTC+HC-06. Do wersji z WiFi tylko reset i komplet Nano+RTC+HC-06.

Najwięcej pierdzielenia okazało się, że miałem ze zmianą nazwy Bluetooth (pomógł film z Youtube) oraz z jednym z Nano, które się programowało a za nic nie mogłem się z nim połączyć - ani po kablu ani po Bluetoooth. Po spieprzonym wieczorze, rano podlutowałem kolejne Nano z szuflady i voila! - działa od strzała.

Tym oto sposobem mam dwie "chinki" z eleganckim sterowaniem i magicznymi wschodami i zachodami. Chinki jak widać na zdjęciach doposażyłem w 2XT5 54W tak dla pewności szerszego spektrum. Trochę jeszcze ogarnę kabelki od T5ątek i będzie najs.

Tak wogóle to mam już Doser'a, Computer'a, i chyba już 4-y Led Controle:)

Dzięki Marcin i sorki, że tam mało daję  na sobie zarobić;) - kupiłem jednie płytkę do Dosera. 

Zdjęcie

Edited by bienki (see edit history)

Share this post


Link to post
Share on other sites

Wtam czy do PWM tego sterownika mogę podpiąć drugą płytkę z dwoma driverami LDD700l i osobnym zasilaczem ? Na tej płytce są dwa kanały po 6 led chciałbym je dołożyć do lampy ze schematu tak by na dwuch kanałach było po 14 ledów, a reszta po 8 led ,dzięki temu zyskałbym dodatkową moc.

arduino.JPG

Przechwytywaniecfvv.JPG

Share this post


Link to post
Share on other sites

Czy tak to powinno wyglądać ? Mam już zbudowaną lampę na podzespołach od AQma przy użyciu między innymi takiej płytki z dwoma driverami i chcę to wykorzystać przy budowie nowej lampy mocniejszej. Mam wątpliwości co do łączenia mas zasilaczy, mają różne parametry, myślałem że wystarczy podpiąć PWM,dlaczego należy zmostkować mase ?

lampa2.0.JPG

Share this post


Link to post
Share on other sites
20 minut temu, SlawwPmi napisał:

Czy tak to powinno wyglądać ? Mam już zbudowaną lampę na podzespołach od AQma przy użyciu między innymi takiej płytki z dwoma driverami i chcę to wykorzystać przy budowie nowej lampy mocniejszej. Mam wątpliwości co do łączenia mas zasilaczy, mają różne parametry, myślałem że wystarczy podpiąć PWM,dlaczego należy zmostkować mase ?

 

A wysiliłeś się choć troszkę i przeczytałeś opis na stronie od magu?

"*** Jeżeli Arduino i drivery LED zasilane są z różnych źródeł należy połączyć masy (minusy) wszystkich użytych zasilaczy (tylko minusy!!!).

****** Jeżeli układ ma więcej niż jeden zasilacz, wszystkie masy muszą być ze sobą połączone, to bardzo ważne, inaczej jest spora szansa, że popali sie cała elektronika

Edited by elespero (see edit history)

Share this post


Link to post
Share on other sites

Mam taką małą zagwostkę bo wszystko działało a od kilku dni walczę z tym żeby przywrócić połączenie bluetooth z komputerem czy telefonem. Niby komputer i telefon wykrywają urządzenie ale po połączeniu jest jakby nieaktywne nie sparowane. Wiecie może o co chodzi? Czy bateria w sterowniku ma tu jakieś znaczenie?

Share this post


Link to post
Share on other sites

Mi na to pomaga wyłączenie i włączenie bluetooth w komputerze.

Share this post


Link to post
Share on other sites

Spróbuj pokombinować z portami, jakimi może się łączyć

Wysłane z mojego SM-G986B przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
39 minut temu, Marijo napisał:

Mi na to pomaga wyłączenie i włączenie bluetooth w komputerze.

Dzisiaj to sprawdzę na kompie ale w telefonie jest tak samo, a bluetooth wyłączam i nadal ten sam objaw niby wykrywa aqmqled ale z nią nie paruje.

3 minuty temu, Alcoholik napisał:

Spróbuj pokombinować z portami, jakimi może się łączyć

Po połączeniu nie ma żadnych portów bo urządzenie nie jest sparowane, nie ma też tego dźwięku sparowania jak łączy. Dziwne.

Share this post


Link to post
Share on other sites

Może wyłącz zasilanie na chwilę sterownika i włącz z powrotem, ja zawsze wyciągam wtyczkę z gniazdka, a porty to na kompie masz, w aplikacji z jakim jest połączone

Wysłane z mojego SM-G986B przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Witam,

A może ktoś ma odsprzedać sterownik z driverami i całym innym osprzętem? Magu nie wysyła aktualnie nic, a mi by się przydało na czas, żeby coś pomodzić przy lampie.

Share this post


Link to post
Share on other sites
Może wyłącz zasilanie na chwilę sterownika i włącz z powrotem, ja zawsze wyciągam wtyczkę z gniazdka, a porty to na kompie masz, w aplikacji z jakim jest połączone

Wysłane z mojego SM-G986B przy użyciu Tapatalka


Strzał w 10 ;) reset sterownika poprzez odłączenie od zasilania pomogło i wróciło połączenie. Dziękuję za pomoc.

Wysłane z mojego LG-H815 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Spoko.
Czasami jak prądu nie ma to się zawiesza i trzeba tak robić.

Wysłane z mojego SM-G986B przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
W dniu 6.04.2020 o 22:13, Alcoholik napisał:

Spoko.
Czasami jak prądu nie ma to się zawiesza i trzeba tak robić.

Wysłane z mojego SM-G986B przy użyciu Tapatalka
 

Moja radość była przedwczesna heh po rozłączeniu i próbie kolejnego podłączenia znowu jest problem sparowania. Pewnie przyjdzie mi wymienić moduł bluetooth HC05.

Share this post


Link to post
Share on other sites
2 godziny temu, =Fresz= napisał:

Moja radość była przedwczesna heh po rozłączeniu i próbie kolejnego podłączenia znowu jest problem sparowania. Pewnie przyjdzie mi wymienić moduł bluetooth HC05.

A próbowałeś zrobić tak, odłączyć aqmę od zasilania (1), usunąć urządzenie z komputera i telefonu, czyli z listy urządzeń sprawowanych (2), włączyć aqmę (3), sparować na nowo urządzenie (4), czyli nie tylko połączyć, ale na nowo sparować?

 

Share this post


Link to post
Share on other sites
12 minut temu, kostkaz3m napisał:

A próbowałeś zrobić tak, odłączyć aqmę od zasilania (1), usunąć urządzenie z komputera i telefonu, czyli z listy urządzeń sprawowanych (2), włączyć aqmę (3), sparować na nowo urządzenie (4), czyli nie tylko połączyć, ale na nowo sparować?

 

Tak robię to z telefonem się połączy i mogę odpalić w aplikacji ale jak rozłączę i chcę ponownie połączyć to znowu nie ma możliwości. Natomiast na komputerze jak robię wszystko od nowa to niby pokaże się port COM ale jak z nim łączę to pokazuje się błąd. Po pracy zrobię zdjęcie i tu wrzucę.

Share this post


Link to post
Share on other sites

Siemka port com, jak naciśniesz możesz zmienić na com1 albo inny, u mnie łączy się z com7, com5 przestal dzialac

Wysłane z mojego SM-G986B przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
10 godzin temu, Alcoholik napisał:
Siemka port com, jak naciśniesz możesz zmienić na com1 albo inny, u mnie łączy się z com7, com5 przestal dzialac

Wysłane z mojego SM-G986B przy użyciu Tapatalka

 

Sprawdzam każdy i jest błąd jak na focie.
Wczoraj np na telefonie za każdym razem już łączyło a na kompie nie. Jakieś dziwy heh

 

f2a181469b158879a950598d0493f99f.jpg

Wysłane z mojego LG-H815 przy użyciu Tapatalka
 

Edited by =Fresz= (see edit history)

Share this post


Link to post
Share on other sites

U mnie był dokładnie ten sam problem ale usunięcie urządzenia sparowanego i jeszcze raz dodanie pomogło.

A czy skoro masz urządzenie sparowane z telefonem i kompem nie wchodzą w konflikt? Próbowałeś usunąć z telefonu i wyłączyć blue w telefonie?

Share this post


Link to post
Share on other sites

Witam. 

Ja miałem podobny problem. Niby telefon łączył się ze sterownikiem, ale po chwili piszczał 2, 3 razy i wywaliło mnie z aplikacji. Próbowałem większości  wyżej wymienionych sposobów, ale nic to nie dawało. Później wpadłem na pomysł żeby zresetować sterownik. Rozkrecilem lampę i przytrzymalem przycisk na sterowniku około 5-10 sekund, już nie pamiętam dokładnie ile, ale sterownik da znać że już się zresetował. Micro przycisk znajduje się na płytce  arduino. 

 

Share this post


Link to post
Share on other sites

Działaj powinno się udać

Wysłane z mojego SM-G986B przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Wchodząc do serwisu Nano-Reef, zgadzasz się na warunki Terms of Use.